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Starting Shorthand
Start Shorthand as you would any Windows applications by clicking its icon from within the 
Windows Program Manager.

Shorthand automatically loads the last dictionary file used.    If you wish to use another 
dictionary, select File | Open or File | New.



Running Shorthand in the Background
Run Shorthand in the background by clicking on the Hide button. 

Pressing ESC or clicking on the minimize button on the main window's title bar does the 
same thing as clicking on the Hide button.

Once Shorthand is in the background, it monitors every keystroke you make; when the hot 
key is detected, Shorthand will activate itself.



Activating Shorthand
If Shorthand is running in the background, you activate Shorthand from within your word 
processor by pressing the hot key character.

If Shorthand is already visible on your screen, you activate it by clicking anywhere inside 
the Shorthand window.



Specifying The Text To Type
In the Keyword box, enter the keyword of the text you wish Shorthand to type for you.    The
text associated with the keyword appears in the Text to Type box.

Alternative Method:    In the Dictionary List box, highlight the desired text by clicking on it.    
The selected text appears in the Text to Type box.



Modifying The Text    To Type
Shorthand must have been activated from within your word processor by pressing the hot 
key.    

Specify the text to type as described in "Specifying the Text to Type."

You can edit the text that is to be typed by directly modifying the text in the Text to Type 
box.    

Shorthand has built-in functions to:

Capitalize First Word
Capitalize All Words
Capitalize Entire Text

Uncapitalize First Word
Uncapitalize All Words
Uncapitalize Entire Text

.



Typing Text Into Your Word Processor
IMPORTANT!
Shorthand always types the text into the window in which you pressed the hot key.

The text that Shorthand will "type" into your word processor is displayed in the Text To Type
box (see "Specifying the Text to Type.")

To command Shorthand to type the text into your word processor:

Click the Type It button.

-OR-

With the focus in the Keyword box (the text caret must be blinking in the Keyword box), 
press ENTER.    (NOTE:    The Keyword box automatically receives the focus whenever 
Shorthand is activated.) 

-OR-

Double-click on the text item in the Dictionary list box.



Introduction
What is Shorthand?
Shorthand is a typing productivity tool designed to work concurrently with a Windows word 
processor or text editor application.    In the same way stenographers use shorthand 
symbols to quickly jot down text, the Shorthand program allows you to replace frequently 
used words or phrases with a much shorter abbreviation or keyword.      Instead of typing in 
the word or phrase, you type the shorter keyword and Shorthand will take care of inserting 
the longer word or phrase into your word processor.    Shorthand is not limited to word 
processors.    It works just as well with most Windows dialog boxes.    Shorthand can be used
to enter names, logins, passwords, internet addresses directly into terminal windows.

How does Shorthand work?
You execute Shorthand as you would any Windows application.    Shorthand waits in the 
background until you need it.    You start your word processor and begin typing normally.    
When you need to use Shorthand, you simply type a hot key and Shorthand pops up and 
takes control.    You specify the text you want Shorthand to type for you by entering a 
keyword or using the mouse to select the text from a list.    If you wish, you may edit the 
text before Shorthand types it into your word processor.

What's the difference between Shorthand and my word processor's macros?
Shorthand and your word processor's macros have the same purpose--to reduce the 
number of keystrokes you need to type commonly used words.    Shorthand has the 
advantage that it is not tied to a single word processor--you can use it with just about every
Windows word processor, text editor, and even with text edit boxes within dialog boxes.    
Shorthand is designed to be much easier to use than the macro abilities of most word 
processors (which usually requires programming); much work has gone into designing a 
user interface that is readily usable by both touch typists and "hunt-and-peck" typists.    

What are the limitations of using Shorthand?
Shorthand text are limited to regular ASCII and some extended ASCII characters; Shorthand
presently has no support for inserting function keys, numeric keypad keys, cursor keys, 
CTRL or ALT key combinations.    Shorthand uses the Windows hooks mechanism to monitor 
and insert characters into the keyboard message queue.    Shorthand may be incompatible 
with applications that use or prevent the use of the Windows keyboard hook to translate or 
playback keyboard characters.



The hot key character is a special character you type from within your word processor to 
call Shorthand into action.    Shorthand must be running in the background for the hot key 
to work.    Shorthand always ignores the hot key if the Shorthand window is visible.



The keyword is a word up to 8 characters long used as an alias or abbreviation to a longer 
word or phrase.



In Windows, all mouse and keyboard input are sent to the window with the "focus."    Text 
edit boxes that have the focus have a blinking caret that specifies where the next character
is to be inserted.    The window that has the focus has its title bar highlighted.



You can highlight an entry in the Dictionary list box in one of three ways:    (1) Click the 
entry with the left mouse button.    (2) Press TAB until you are in the Dictionary list box, then
use the cursor up/down keys to scroll through the list.    (3) Enter the the entry's keyword in 
the Keyword box.
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The Main Window
The Main Menu
File Provides functions to create, open, and save dictionary files.    In addition the

change preference function is located here.
Caps Provides functions to capitalize/uncapitalize the text in the Text to Type box.
Dictionary Provides functions to add, modify or remove dictionary entries.
Help Provides help information functions.

Text Edit Boxes
Keyword Enter the keyword of a dictionary in this box.    The Keyword box is enabled 

only if Shorthand was activated from within your word processor.
Text To Type The text associated with the keyword you entered or selected in the 

Dictionary list box appears in the Text to Type box.    You can edit the text in 
this box.    The Text to Type box is enabled only if Shorthand was activated 
from within your word processor.

List Box
Dictionary Displays keywords and their associated text.

Buttons
Type It Click this button to command Shorthand to "type" the contents of the Text 

to Type box into your word processor. 
Hide Click this button to tell Shorthand to minimize itself and wait in the 

background for the hot key character.
Date Click this button to command Shorthand to "type" the current date into your

word processor.    Shorthand uses the Windows "Long Date Format" when 
typing the date.    You can modify the Windows Long Date Format through 
the "Regional Settings" icon in the Windows 95 Control Panel.



The Dictionary
Shorthand maintains a "dictionary" which is a list of keywords and their associated text.    
The number of entries is limited only by the amount of Windows memory and resources.



The Status Bar
The Status Bar is located at the bottom of the Main Window.    It displays context sensitive 
help and the currently hot key character.



Using the Right Mouse Button
You can use the right mouse to button to bring up context-sensitive popup menus.

Clicking the right mouse button anywhere inside the Text to Type box brings up a menu for 
capitalizing or uncapitalizing the text in the Text to Type box.

Clicking the right mouse button anywhere inside the Dictionary list box brings up a menu 
for adding, modifying or removing dictionary entries.



Effect of the CAPS LOCK, SHIFT, CTRL Keys
The text in the Text to Type box is inserted into your word processor as it appears in the 
Text to Type box, regardless of the state of the CAPS LOCK, SHIFT and CTRL keys.



Compatibility Issues
Shorthand is designed to work with applications running under Windows 95.

Shorthand works with any Windows application that uses the normal Windows keyboard 
messages as input.    Applications that takes its input directly from the keyboard hardware 
interrupt (such as DOS applications) will not work with Shorthand.

Shorthand uses the Windows hooks mechanism to insert characters into the keyboard 
message queue.    Shorthand may be incompatible with applications that use the Windows 
keyboard hooks to translate or playback keyboard characters.

Shorthand may not work with applications that use the Windows 95/NT security functions to
prevent other applications (such as Shorthand) from monitoring them.    

If the Use Clipboard When Typing Text box is checked in the Preferences dialog box, 
Shorthand uses the Windows Clipboard to transfer text.    For this method to work, the 
application receiving the text must recognize the standard Shift+Insert key command to 
paste text from the Clipboard.



Creating a New Dictionary
Selecting "New" from the File menu creates a new dictionary.



Opening a Dictionary File
Selecting "Open..." from the File menu opens and loads a dictionary file.



Saving the Dictionary
Selecting "Save" from the File menu saves the dictionary to a disk file.



Renaming the Dictionary
Selecting "Save As..." from the File menu saves the dictionary to another disk file.



Exiting Shorthand
Selecting "Exit" from the File menu terminates the Shorthand application.



Adding a New Dictionary Entry
Selecting "Add" from the Dictionary menu brings up the Add a New Dictionary Entry dialog 
box.



Modifying an Existing Dictionary Entry
Selecting "Modify" from the Dictionary menu brings up the Modify Dictionary Entry dialog 
box.



Removing an Existing Dictionary Entry
Selecting "Remove..." from the Dictionary menu will delete the selected (highlighted) entry 
in the Dictionary list box.

There are two alternate methods to delete an entry from the dictionary:

Highlight the desired entry to delete in the Dictionary list box then press CTRL+R from your
keyboard to delete it.

-OR-

Highlight the desired entry to delete in the Dictionary list box then click the right mouse 
button anywhere inside the Dictionary list box and select "Remove... " from the popup 
menu.
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Preferences
Selecting "Preferences..." from the File menu brings up the Preferences dialog box.



Converting the Entire Text to Uppercase
Selecting "Capitalize All Text" from the Caps menu will convert all characters in the Text to 
Type box to uppercase.

Alternative Method
Press ALT+ENTER to command Shorthand to type the text in the Text to Type box into your 
word processor with all characters in uppercase.



Converting the Entire Text to Lowercase
Selecting "Uncapitalize All Text" from the Caps menu will convert all characters in the Text 
to Type box to lowercase.



Capitalizing the First Word
Selecting "Capitalize First Word" from the Caps menu will convert the first character of the 
first word in the Text to Type box to uppercase.

Alternative Method
Press CTRL+ENTER to command Shorthand to type the text in the Text to Type box into 
your word processor with the first character of the first word in uppercase.



Uncapitalizing the First Word
Selecting "Uncapitalize First Word" from the Caps menu will convert the first character of 
the first word in the Text to Type box to lowercase.



Capitalizing All Words
Selecting "Capitalize All Words" from the Caps menu will convert the first character of every
word in the Text to Type box to uppercase.

Alternative Method
Press SHIFT+ENTER to command Shorthand to type the text in the Text to Type box into 
your word processor with the first character of every word in uppercase.



Uncapitalizing All Words
Selecting "Uncapitalize All Words" from the Caps menu will convert the first character of 
every word in the Text to Type box to lowercase.



The About Shorthand Dialog Box
Selecting "About Shorthand..." from the Help menu brings up a dialog box that displays the 
Shorthand version number and copyright information. 



The Add a New Dictionary Entry Dialog Box
This dialog box allows you to add a new keyword and its associated text to the dictionary.

There are several ways to bring up the dialog box:
1. Select "Add..." from the Dictionary menu.

-OR-
2. Press CTRL+A from your keyboard.

-OR-
3. Click the right mouse button anywhere in the Dictionary list box, and select "Add... " 

from the popup menu.

Keyword
Enter a unique keyword (up to 8 characters) in the Keyword box.    If you enter a keyword 
that already exists in the dictionary, an error message will be displayed.

Text
Enter the text that is to be associated with the keyword in the Text box.    Note: Pressing the
ENTER key in the text box will insert a "new line" (carriage return/linefeed) into the text.

Buttons
The following buttons affect only the Text box.
Undo Undo the last edit operation.
Copy Copy the selected text to the clipboard.
Cut Delete the selected text.
Paste Paste the contents of the clipboard to the Text box.



The Modify Dictionary Entry Dialog Box
This dialog box allows you to add a modify a keyword or its associated text in the 
dictionary.

There are several ways to bring up the dialog box:
1. Highlight the desired entry to modify in the Dictionary list box and then select 

"Modify..." from the Dictionary menu.
-OR-

2. Highlight the desired entry to modify in the Dictionary list box and then press CTRL+M
from your keyboard.

-OR-
3. Highlight the desired entry to modify in the Dictionary list box and then click the right 

mouse button anywhere inside the Dictionary list box and select "Modify... " from the 
popup menu.

Keyword
You can change the keyword in the Keyword box.    If you enter a keyword that already 
exists in the dictionary, a warning message will be displayed.

Text
Enter the text that is to be associated with the keyword in the Text box.    Note:    Pressing 
the ENTER key in the text box will insert a "new line" (carriage return/linefeed) into the text.

Buttons
The following buttons affect only the Text box.
Undo Undo the last edit operation.
Copy Copy the selected text to the clipboard.
Cut Delete the selected text.
Paste Paste the contents of the clipboard to the Text box.



The Preferences Dialog Box
Selecting "Preferences..." from the File menu brings up a dialog box that allows you to 
change the hot key character and edit sound options.

Hot Key Character
Select the hot key character from the list.

Beep When Hot Key Pressed
When this option is checked, the PC speaker will beep whenever you hit the hot key to 
activate Shorthand.

Beep When Typing Empty Text String
When this option is checked, the PC speaker will beep when Shorthand has nothing to type 
(that is, when there is no text in the Text to Type box; this can occur if you enter a non-
existent keyword and press the ENTER key).

Run Minimized
When this option is checked, Shorthand will automatically hide itself when you first execute
the program.    This is useful if you want to execute Shorthand automatically by placing it in 
Window 95's Startup folder.

Enable Quick Keyboard Input
When this option is checked, there is no need to hit the ENTER key after typing in the 
keyword.    For example, if you have a keyword called "asap" and you have no other 
keyword beginning with "asap", you need only type the hot key + "asap" (instead of the hot
key+"asap" + ENTER) from your word processor to transfer the text associated with the 
"asap" keyword.

Use Clipboard When Typing Text
When this option is checked, Shorthand uses the Clipboard to transfer the text.    If this 
option is not checked, Shorthand types the text by simulating keyboard input.    By default, 
Shorthand uses the Clipboard to transfer the text.    If you are unable to make Shorthand 
work with some applications you might want to try to disable the Use Clipboard option.

The advantages of using the Clipboard to transfer text are:
1. Fast text transfer.
2. Supports extended characters and international (not United States) keyboards.

The disadvantage of using the Clipboard to transfer text is:
1. Receiving application must support the Shift+Insert keystroke command to paste text 

from the Clipboard.

The advantage of using keyboard simulation to transfer text is:
1. Works with most Windows applications when typing standard ASCII characters.

The disadvantages of using keyboard simulation to transfer text are:
1. Slow text transfer with certain applications.
2. May not work with certain applications when typing extended characters.
3. May not work with certain applications when using a non-U.S. keyboard.




